配置AC
2.4G和5G射频+VRRP+MSTP
AC1:
#
vlan batch 100 to 101
#
stp enable
#
stp region-configuration
region-name sjg
instance 1 vlan 101
instance 2 vlan 100
active region-configuration
#
interface Vlanif100
ip address 100.100.100.3 255.255.255.0
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100
#
interface Wlan-Ess1
port hybrid pvid vlan 101
port hybrid untagged vlan 101
#
ospf 10 router-id 3.3.3.3
area 0.0.0.0
network 100.100.100.0 0.0.0.255
#
wlan
wlan ac source interface vlanif100
ap-region id 10
ap id 1 type-id 19 mac 00e0-fc23-8080 sn 210235448310444A471B
keep-service enable
region-id 10
ap id 2 type-id 19 mac 00e0-fc63-0b40 sn 210235448310F9344F69
keep-service enable
region-id 10
wmm-profile name wmm id 1
wmm-profile name a1 id 2
traffic-profile name tra id 1
traffic-profile name b1 id 2
security-profile name sec id 1
security-policy wpa2
wpa2 authentication-method psk pass-phrase cipher 12345678 encryption-method ccmp
security-profile name c1 id 2
service-set name ser id 1
wlan-ess 1
ssid sjg \\信号为sjg需输入密码12345678
traffic-profile id 1
security-profile id 1
service-vlan 101
service-set name d1 id 2
wlan-ess 1
ssid Guest \\信号为Guest无密码,直接连接就可以
traffic-profile id 2
security-profile id 2
service-vlan 101
radio-profile name 5G id 0 \\创建名为5G的射频模板
radio-type 80211an \\设定模板射频类型为802.11an,5G最大
兼容
wmm-profile id 2 \\绑定a1模板至射频模板
80211n guard-interval-mode short \\/开启short GI,默认未开启
radio-profile name rad id 1
wmm-profile id 1
ap 1 radio 0
radio-profile id 1
service-set id 1 wlan 1
ap 2 radio 1 \\进入AP1的5G射频
radio-profile id 0 \\绑定5G射频模板
channel 40MHz-plus 149 \\/设置信道带宽为40MHz-plus 149
service-set id 2 wlan 1
commit all
S1:
#
sysname S1
#
vlan batch 10 100 to 101
#
stp instance 1 root primary
stp instance 2 root primary
stp instance 3 root secondary
#
dhcp enable
#
stp region-configuration
region-name sjg
instance 1 vlan 101
instance 2 vlan 100
instance 3 vlan 10
active region-configuration
#
ip pool guanli
gateway-list 100.100.100.254
network 100.100.100.0 mask 255.255.255.0
excluded-ip-address 100.100.100.2 100.100.100.3
#
ip pool wuxian
gateway-list 172.100.23.254
network 172.100.20.0 mask 255.255.252.0
excluded-ip-address 172.100.23.253
dns-list 8.8.8.8
#
ip pool youxian
gateway-list 192.168.1.254
network 192.168.1.0 mask 255.255.255.0
dns-list 8.8.8.8
#
interface Vlanif10
ip address 192.168.1.253 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.1.254
dhcp select global
#
interface Vlanif100
ip address 100.100.100.1 255.255.255.0
vrrp vrid 1 virtual-ip 100.100.100.254
vrrp vrid 1 priority 105
dhcp select global
#
interface Vlanif101
ip address 172.100.23.254 255.255.252.0
vrrp vrid 1 virtual-ip 172.100.23.254
vrrp vrid 1 priority 105
dhcp select global
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 10 100 to 101
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 100
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 100 to 101
#
interface GigabitEthernet0/0/19
eth-trunk 1
#
interface GigabitEthernet0/0/20
eth-trunk 1
#
ospf 10 router-id 1.1.1.1
area 0.0.0.0
network 100.100.100.0 0.0.0.255
network 172.100.20.0 0.0.3.255
network 192.168.1.0 0.0.0.255
S2:
#
sysname S2
#
vlan batch 10 100 to 101
#
stp instance 1 root secondary
stp instance 2 root secondary
stp instance 3 root primary
#
dhcp enable
#
stp region-configuration
region-name sjg
instance 1 vlan 101
instance 2 vlan 100
instance 3 vlan 10
active region-configuration
#
ip pool guanli
gateway-list 100.100.100.254
network 100.100.100.0 mask 255.255.255.0
excluded-ip-address 100.100.100.1 100.100.100.3
#
ip pool wuxian
gateway-list 172.100.23.254
network 172.100.20.0 mask 255.255.252.0
dns-list 8.8.8.8
#
ip pool youxian
gateway-list 192.168.1.254
network 192.168.1.0 mask 255.255.255.0
excluded-ip-address 192.168.1.253
dns-list 8.8.8.8
#
interface Vlanif10
ip address 192.168.1.254 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.1.254
vrrp vrid 1 priority 105
dhcp select global
#
interface Vlanif100
ip address 100.100.100.2 255.255.255.0
vrrp vrid 1 virtual-ip 100.100.100.254
dhcp select global
#
interface Vlanif101
ip address 172.100.23.253 255.255.252.0
vrrp vrid 1 virtual-ip 172.100.23.254
dhcp select global
#
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 10 100 to 101
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 100 to 101
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 100
#
interface GigabitEthernet0/0/19
eth-trunk 1
#
interface GigabitEthernet0/0/20
eth-trunk 1
#
ospf 10 router-id 2.2.2.2
area 0.0.0.0
network 100.100.100.0 0.0.0.255
network 172.100.20.0 0.0.3.255
network 192.168.1.0 0.0.0.255
S3:
#
sysname S3
#
vlan batch 10 100 to 101
#
stp region-configuration
region-name sjg
instance 1 vlan 101
instance 2 vlan 100
instance 3 vlan 10
active region-configuration
#
interface Ethernet0/0/1
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 to 101
#
interface Ethernet0/0/2
port link-type access
port default vlan 10
#
interface Ethernet0/0/3
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100 to 101
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 10 100 to 101
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 10 100 to 101